Archive for March, 2004

Battlefield Vietnam

Monday, March 29th, 2004

Last weekend I bought Battlefield Vietnam. I hadn’t played Battlefield 1942 too much, so it was kinda a gamble as to whether I would like it or not. I’m glad I bought it, because I love it! I generally suck at video games, but I love hopping on a big server and running around shooting people. Adding to the fun is the fact that I can drive tanks, APCs, jeeps, helicopters, planes, and even a scooter!

The one thing I dislike about the game is the M60 on the US side. It’s like a BFG from “other” games. It’s insanely accurate, has a high rate of fire, and very deadly. The gunner also either gets a grenade launcher or a LAW. The LAW and M60 combo is deadly against the enemy, almost unfair. Hopefully EA will fix the problem in a patch.

One of my favorite things to do is play as a sniper and set myself up a little ways from the enemy base.. Guys will spawn then stand around waiting for a helicopter to appear, making it incredibly easy to get headshots on them and drop em like flies. Gotta be kinda demoralizing to just be standing around and suddenly drop dead.. even moreso when I manage to get a guy twice in a row.

I’ll have to put up some of my screenshots sometime soon…

ATI Radeon 9800 PRO (more)

Tuesday, March 2nd, 2004

I’ve been using my ATI Radeon 9800 PRO for a little over a week now. I’m loving it. Not a big benchmark fan, so I haven’t bothered overclocking it. I’m mainly playing America’s Army and I can play with all the details cranked up and still get a decent FPS of ~50-70. Lovely.

But ATI’s drivers in Linux absolutely SUCK. I get some terrible distortion while playing AA after about a minute in a map. Game is absolutely beautiful in Windows, so I find myself booting over just to play that game. I’ve found a couple other people with the same problem, so I guess it really is a driver issue. I’ve tried two different versions of the driver (3.2.8 and 3.7.0) and get the same problem.

And GameVE continues to cause problems for me. They issued a refund, but it was only a partial refund. I’ve tried calling them a couple times but can’t get ahold of the manager. I emailed them and asked about it, but no reply yet. In the meantime, I’ve filed complaints with the BBB, California Attorney General, and the Federal Trade Commission. They sold me a used, old, defective product and advertised it as brand new. Now they’re hassling me about giving me my money back. So screw em.