Archive for March 3rd, 2009

Samsung LN-T4065F Slow Changing Channels

Tuesday, March 3rd, 2009

I’ve had my Samsung LN-T4065F for about 14 months now. For the first 13 months, it was mostly trouble free. Couple hiccups with 1080p sources here and there, but nothing I couldn’t live with.

But, for the past month or so, I’ve been having this problem with the TV being VERY, VERY slow to change channels. Not just two or three seconds, but closer to 10 seconds. Sometimes I am able to power cycle the TV and it’ll go back to normal for a while, sometimes not. I’ve done an auto-program several times to no avail. I’ve gone in to the service menu and done a full reset on the tv. It was better for a few hours, but then went right back to being slow.

Note that I’m connected straight to the wall with my cable — no cable box. Samsung just says to have Comcast “reset my signal,” whatever that means. Not sure the rep even knew, it was just something to get me to go away because the Samsung TV is now 1 month out of warranty. Pretty much the brush off. Their reps don’t sign their names and there’s no ticket number or anything. Pretty poor experience with them, really.

I have another TV, well, TV tuner in my computer, and it has zero problems changing channels. I really, really doubt it’s a Comcast problem. But, since Samsung doesn’t care, I guess that’s my only recourse. Until I get tired of it and buy a Panasonic or Sony.

Here’s a video showing how slow it is. It starts on the HD channel, then I hit down to go to the SD channel, then right back up to HD.